MyTetra Share
Делитесь знаниями!
актуальное зеркало Буй
1С: Как получить ссылку по уникальному идентификатору
Время создания: 13.12.2012 13:34
Текстовые метки: 1С, ссылка, уникальный идентификатор GUID
Раздел: Компьютер - Windows - 1С - Готовые решения
Запись: xintrea/mytetra_syncro/master/base/1355391258eb8jayr8xd/text.html на raw.github.com

Для получения ссылки по уникальному идентификатору, используйте код:

// ГУИД = 05dbe824-a4c6-11dd-bf56-00145e3710ab

// Ссылка будет установлена в переменную СсылкаНаОбъектГуид

УникальныйИдентификатор = Новый УникальныйИдентификатор(ГУИД)

// все объекты по которым можно получить ссылку

Если ПолучитьСсылкуНоМенеджеруОбъекта(Справочники,УникальныйИдентификатор) Тогда

ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(Документы,УникальныйИдентификатор) Тогда

ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыВидовХарактеристик,УникальныйИдентификатор) Тогда

ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыСчетов,УникальныйИдентификатор) Тогда

ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыОбмена,УникальныйИдентификатор) Тогда

ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(БизнесПроцессы,УникальныйИдентификатор) Тогда

ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(Задачи,УникальныйИдентификатор) Тогда

КонецЕсли;

// ПолучитьСсылкуНоМенеджеруОбъекта()

Функция ПолучитьСсылкуНоМенеджеруОбъекта(ОбъектыМенеджер,УникальныйИдентификатор)

Для Каждого Менеджер Из ОбъектыМенеджер Цикл

СсылкаНаОбъектГуид = Менеджер.ПолучитьСсылку(УникальныйИдентификатор);

Если СсылкаНаОбъектГуид.ПолучитьОбъект() <> Неопределено Тогда

Возврат Истина;

КонецЕсли;

КонецЦикла;

Возврат Ложь;

КонецФункции

Так же в этом разделе:
 
MyTetra Share v.0.55
Яндекс индекс цитирования