MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
1С 8.2: Как выбрать (перебрать) все элементы из определенной группы
09.11.2012
13:53
Раздел: Компьютер - Windows - 1С - Готовые решения

Для выполнения этого действия следует помнить, что в терминах 1С:Предприятия Группа - это Родитель.

Вриант 1

//ПолеВводаРодитель - поле на форме

Выборка = Справочники.Номенклатура.Выбрать(ПолеВводаРодитель);

Пока Выборка.Следующий() Цикл

Наименование = Выборка.Наименование;

КонецЦикла;

Вариант 2

Запрос = Новый Запрос("

|ВЫБРАТЬ

| Ссылка,

| Наименование

|ИЗ

| Справочник.Номенклатура

|ГДЕ

| Родитель = &Родитель

|АВТОУПОРЯДОЧИВАНИЕ");

Запрос.УстановитьПараметр("Родитель", ПолеВводаРодитель);

Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл

Наименование = Результат.Наименование;

КонецЦикла;

Вариант 3

Выборка=Справочники.Номенклатура.ВыбратьИерархически(ПолеВводаРодитель);

Пока Выборка.Следующий() Цикл

Наименование = Выборка.Наименование;

КонецЦикла;

Вариант 4

Запрос = Новый Запрос("

|ВЫБРАТЬ

| Ссылка,

| Наименование

|ИЗ

| Справочник.Номенклатура

|ГДЕ

| Родитель В ИЕРАРХИИ(&Родитель)

|АВТОУПОРЯДОЧИВАНИЕ");

Запрос.УстановитьПараметр("Родитель", ПолеВводаРодитель);

Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл

Наименование = Результат.Наименование;

КонецЦикла;

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования