MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Пример выгрузки в XML, вариант 2
10.04.2012
12:18
Текстовые метки:
Раздел: Компьютер - Windows - 1С - Готовые решения

&НаСервере

Процедура ПолучитьДанные()

Запись=Новый ЗаписьXML;

Запись.ОткрытьФайл("c:\document.xml");

Запись.ЗаписатьОбъявлениеXML();

Запись.ЗаписатьНачалоЭлемента("Документы");

Запись.ЗаписатьНачалоЭлемента("Приходные");

//Запись.ЗаписатьАтрибут("Документ", "ПриходнаяНакладная");

//Запись.ЗаписатьКомментарий("Краткая информация о принятых к учету ОС");

Выборка=Документы.ПриходнаяНакладная.Выбрать(ДатаС,ДатаПо);

Пока Выборка.Следующий() Цикл

Если Выборка.Проведен=Истина тогда

Запись.ЗаписатьНачалоЭлемента("Приходная");

Запись.ЗаписатьАтрибут("Номер", Строка(Выборка.Номер));

Запись.ЗаписатьАтрибут("Дата", Строка(Выборка.Дата));

Запись.ЗаписатьНачалоЭлемента("ТабличнаяЧасть");

Для Каждого ТекущаяСтрока Из Выборка.ПереченьНоменклатуры Цикл

Запись.ЗаписатьНачалоЭлемента("Номенклатура");

Запись.ЗаписатьАтрибут("Номенклатура", Строка(ТекущаяСтрока.Номенклатура));

Запись.ЗаписатьАтрибут("КодНоменклатуры", Строка(ТекущаяСтрока.Номенклатура.Код));

Запись.ЗаписатьАтрибут("Количество", Строка(ТекущаяСтрока.Количество));

Запись.ЗаписатьАтрибут("Цена", Строка(ТекущаяСтрока.Цена));

Запись.ЗаписатьАтрибут("Сумма", Строка(ТекущаяСтрока.Сумма));

Запись.ЗаписатьКонецЭлемента();

КонецЦикла;

Запись.ЗаписатьКонецЭлемента();

Запись.ЗаписатьКонецЭлемента();

КонецЕсли;

КонецЦикла;

Запись.ЗаписатьКонецЭлемента();

Запись.ЗаписатьКонецЭлемента();

Запись.Закрыть();

Сообщить("выгружено!");

КонецПроцедуры

&НаКлиенте Процедура ВыгрузкаXML(Команда)

ПолучитьДанные();

КонецПроцедуры

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования