MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Пример разделения прав доступа (Шпаков)
13.04.2012
11:21
Раздел: Компьютер - Windows - 1С - Готовые решения

Вот пример.


ПараметрыСеанса.ТекущийСотрудник = Справочники.Сотрудники.ПустаяСсылка();

СписокПользователей = ПолучитьСоединенияИнформационнойБазы();

ТекущийПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();

НомерСоединения = НомерСоединенияИнформационнойБазы();

Для Каждого ВыбПользователь Из СписокПользователей Цикл


Если ВыбПользователь.Пользователь<>Неопределено И ТекущийПользователь.Имя = ВыбПользователь.Пользователь.Имя И ВыбПользователь.НомерСоединения<>НомерСоединения Тогда


Сообщить("Пользователем "+ТекущийПользователь.Имя+" уже выполнен вход в систему с компьютера "+ВыбПользователь.ИмяКомпьютера+Символы.ПС+"Этот сеанс будет завершён.",180);

ЗавершитьРаботуСистемы(Ложь);

Возврат;

КонецЕсли;

КонецЦикла;



ПараметрыСеанса.ТекущийСотрудник = Справочники.Сотрудники.ПустаяСсылка();

ПараметрыСеанса.Филиал = Справочники.Филиалы.ПустаяСсылка();

ПодключитьОбработчикОжидания("ПроверкаНаВыход", 15);

ТекущийСотрудник = Справочники.Сотрудники.НайтиПоРеквизиту("Пользователь",ИмяПользователя());


Если ТекущийСотрудник = Справочники.Сотрудники.ПустаяСсылка() Тогда

ТекущийСотрудник = Справочники.Сотрудники.НайтиПоРеквизиту("Пользователь2",ИмяПользователя());

Если ТекущийСотрудник = Справочники.Сотрудники.ПустаяСсылка() Тогда

Предупреждение("Вы не зарегистрированы в системе как сотрудник. Доступ запрещен!",10);


Если Найти(СтрокаСоединенияИнформационнойБазы(),"empv8")>0 Тогда

Если Не РольДоступна("Администратор") Тогда

ЗавершитьРаботуСистемы();

Возврат;

КонецЕсли;

КонецЕсли;


Иначе

ПараметрыСеанса.ТекущийСотрудник=ТекущийСотрудник;

КонецЕсли;


Иначе

ПараметрыСеанса.ТекущийСотрудник=ТекущийСотрудник;

КонецЕсли;



Есть справочник "Сотрудники", в нем два реквизита: "Пользователь" и "Пользователь2", на этом и основано.



Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования