MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Пример вызова произвольной формы со списком выбора
10.04.2012
10:14
Текстовые метки: 1С, радиокнопка, выбор, checkbox
Раздел: Компьютер - Windows - 1С - Готовые решения

Сделана форма, в которой значение списка выбора помещается в реквизит формы РежимСоздания. Вызвать такую форму можно следующим образом:

// Процедура предназначена для интерактивного создания

// нового Файла

// В частности, происходит вызов диалога выбора режима

// создания Файла

// Параметры:

// ВладелецФайла - определяет группу, в которой создается

// Элемент, если группа неизвестна в момент вызова этого

// метода - там будет Неопределено

Процедура СозданиеНовогоФайла(ВладелецФайла,

ФормаВладелец) Экспорт

Форма=РаботаСФайламиКлиентПовтИсп.

ПолучитьФормуВыбораВариантаСозданияНовогоФайла();

Форма.РежимСоздания = 1; // Создаем из шаблона

Результат = Форма.ОткрытьМодально();

Если Результат = КодВозвратаДиалога.Да Тогда

СоздатьФайл(Форма.РежимСоздания, ВладелецФайла, ФормаВладелец);

КонецЕсли;

КонецПроцедуры // СозданиеНовогоФайла()

// Возвращает форму, которая используется при создании

// нового файла для выбора варианта создания

Функция ПолучитьФормуВыбораВариантаСозданияНовогоФайла() Экспорт

Возврат ПолучитьФорму("Справочник.Файлы.Форма.ФормаНового");

КонецФункции

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования