MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Как получить владельца формы подчиненного справочника
01.11.2012
10:34
Автор: xintrea
Текстовые метки: 1С, владелец
Раздел: Компьютер - Windows - 1С - Готовые решения

Если справочник подчиненный (т.е. имеет владельца), то обычно на форме списка или на форме выбора, автоматически сгенерированной системой 1С, прописан отбор по владельцу.

Вопрос - как в модуле формы узнать, какой владелец установлен для списка?

Далее приведен код, выясняющий владельца списка справочника. Код надо размещать в модуле формы. Предполагается, что на форме автоматически был создан реквизит Список, который содержит данные справочника.

&НаСервере

Функция ПолучитьВладельцаФормы()

КоллекцияПолейОтбора=ЭтаФорма.Список.Отбор.Элементы;

ТекущийВладелецФормы=Неопределено;

Для каждого ПолеОтбора Из КоллекцияПолейОтбора Цикл

Если Строка(ПолеОтбора.ЛевоеЗначение)="Владелец" Тогда

ТекущийВладелецФормы=ПолеОтбора.ПравоеЗначение;

Прервать;

КонецЕсли;

КонецЦикла;

Возврат ТекущийВладелецФормы;

КонецФункции

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования