MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Ошибка при выполнении запроса из консоли запросов
16.01.2017
10:15
Текстовые метки: devtool1c
Раздел: Программирование - 1с - devtools - Исправления в коде подсистемы - ДО

Исправление


ирОбщий.epf

В процедуре "СохранитьФайлВКонсолиСВосстановлениемЛкс" добавлен код попытки:


Если СохранитьФайл Тогда

Если Истина

И НРег(ИмяСохраняемогоФайла) = НРег(ФайлВосстановления.ПолноеИмя)

И БлокировкаВосстановления <> Неопределено

Тогда

БлокировкаВосстановления = Неопределено;

КонецЕсли;

ЗначениеВФайл(ИмяСохраняемогоФайла, ДанныеДляФайла);

Если НРег(ИмяСохраняемогоФайла) = НРег(ФайлВосстановления.ПолноеИмя) Тогда

Попытка

БлокировкаВосстановления = Новый ЗаписьТекста(ИмяСохраняемогоФайла,,,Истина);

Исключение

ЗаписьЖурналаРегистрации("Error.ВнешняяОбработка.ирОбщий", , , , ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));

БлокировкаВосстановления = Неопределено;

КонецПопытки;

КонецЕсли;


КонецЕсли;


Так же в этом разделе:
 
MyTetra Share v.0.46
Яндекс индекс цитирования