MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Проверка среды выполнения
14.12.2016
16:56
Автор: pola
Текстовые метки: 1с_xUnitFor1C
Раздел: Программирование - 1с - Тестирование - Модульное - xUnit - code

Процедура ПередЗапускомТеста() Экспорт

ПроверитьСредуВыполненияТеста();

КонецПроцедуры


#Область Проверить_среду_выполнения_теста

Процедура ПроверитьСредуВыполненияТеста()

ИмяБазы1С = ПолучитьИмяТестовойБазы();

Если СтрНайти(НРег(ИмяБазы1С), "upp") = 0 Тогда

КонтекстЯдра.ПропуститьТест("Тест предназначен для копии УПП с данными");

КонецЕсли;

КонецПроцедуры


Функция ПолучитьИмяТестовойБазы()

ПараметрыПодключения = ОбщегоНазначенияКлиентСервер.ПолучитьПараметрыПодключенияИзСтрокиСоединенияИнформационнойБазы(СтрокаСоединенияИнформационнойБазы());

Возврат ПараметрыПодключения.ИмяИнформационнойБазыНаСервере1СПредприятия;

КонецФункции

#КонецОбласти


Так же в этом разделе:
 
MyTetra Share v.0.46
Яндекс индекс цитирования