MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Индикация упавшего по неизвестной причине тест
16.09.2016
19:49
Раздел: Программирование - 1с - Тестирование - Функциональное - xUnit - Мои изменения в обработке xUnitFor1c

&НаКлиенте

Процедура ОбработатьСобытиеВыполненияТестов(Знач ИмяСобытия, Знач Параметр) Экспорт

Если ИмяСобытия = Объект.ВозможныеСобытия.ВыполненТестовыйМетод Тогда

Если Параметр.Состояние = Объект.СостоянияТестов.НеРеализован Тогда

Если Элементы.ИндикаторВыполнения.ЦветРамки <> WebЦвета.Красный Тогда

Элементы.ИндикаторВыполнения.ЦветРамки = WebЦвета.Золотой;

КонецЕсли;

ИначеЕсли Параметр.Состояние = Объект.СостоянияТестов.Сломан

ИЛИ Параметр.Состояние = Объект.СостоянияТестов.НеизвестнаяОшибка Тогда

Элементы.ИндикаторВыполнения.ЦветРамки = WebЦвета.Красный;

КонецЕсли;

ИндикаторВыполнения = ИндикаторВыполнения + 1;

КонецЕсли;

ОбновитьОтображениеДанных();

КонецПроцедуры

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования