MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Получить тестовый объект
14.09.2016
14:29
Автор: pola
Текстовые метки: 1c.testing.xunit.mylib
Раздел: Программирование - 1с - Тестирование - Функциональное - xUnit - my lib

// Получение разрабатываемого объекта

// ДополнительныйПуть - дополнительный путь относительно пути каталога проекта; без начальных и конечных "\"

Функция ПодключитьТестовыйОбъект(ИмяОбъекта, ДополнительныйПуть = "")

Если Найти(ИмяОбъекта, "epf") > 0 Тогда

Менеджер = ВнешниеОбработки;

ИначеЕсли Найти(ИмяОбъекта, "erf") > 0 Тогда

Менеджер = ВнешниеОтчеты;

Иначе

ВызватьИсключение "Имя объекта не является именем внешней обработки или внешнего отчета";

КонецЕсли;

//ПутьКаталогаОбъекта = ОпределитьПутьКаталогаПроекта() + ДополнительныйПуть;

ИмяФайлаТестовогоОбъекта = ПолучитьИмяВременногоФайла();

Попытка

ДвоичныеДанные = Новый ДвоичныеДанные(ОпределитьПутьОбъекта(ДополнительныйПуть) + ИмяОбъекта);

ДвоичныеДанные.Записать(ИмяФайлаТестовогоОбъекта);

Исключение

Сообщить(ОписаниеОшибки());

ВызватьИсключение "Ошибка создания двоичных данных тестового объекта";

КонецПопытки;

ТестовыйОбъект = Менеджер.Создать(ИмяФайлаТестовогоОбъекта);

УдалитьФайлы(ИмяФайлаТестовогоОбъекта);

Возврат ТестовыйОбъект;

КонецФункции

Функция ОпределитьПутьОбъекта(ДополнительныйПуть)

Разделитель = "\";

МассивПодстрок = СтрРазделить(ЭтотОбъект.ИспользуемоеИмяФайла, Разделитель);

ПутьКаталогаПроекта = МассивПодстрок[0];

Счетчик = 1;

Пока Счетчик < МассивПодстрок.Количество() - 2 Цикл

ПутьКаталогаПроекта = ПутьКаталогаПроекта + Разделитель + МассивПодстрок[Счетчик];

Счетчик = Счетчик + 1;

КонецЦикла;

Возврат ПутьКаталогаПроекта + Разделитель + ДополнительныйПуть + Разделитель;

КонецФункции

ТестовыйОбъект = ПодключитьТестовыйОбъект("УстановкаВладельцевНМА.epf");

Ожидаем.Что(ТестовыйОбъект.Метаданные().Имя).Заполнено();

← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования