MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Удалить тестовые данные
07.09.2016
15:51
Автор: artbear
Текстовые метки: 1c.testing.xunit
Раздел: Программирование - 1с - Тестирование - Функциональное - xUnit

// ТестовыеДанные - структура, содержащая ссылки на удаляемые объекты

&НаКлиенте

Процедура ПослеЗапускаТеста() Экспорт

КонтекстЯдра.ВывестиСообщение("После запуска теста");

УдалитьТестовыеДанныеСервер(ЮнитТестированиеИмя);

ЗавершитьВсеСеансыРаботыСТестовымиПриложениями();

КонецПроцедуры

&НаСервере

Процедура УдалитьТестовыеДанныеСервер(Знач ЮТестПуть)

Если ТестовыеДанныеУФ.Количество() = 0 Тогда

Возврат;

КонецЕсли;

ГенераторТестовыхДанных = ГенераторТестовыхДанных();

ТестовыеДанные = Новый Структура;

Для каждого Строка Из ТестовыеДанныеУФ Цикл

Если Строка.Ключ = "ПользовательИнформационнойБазы" Тогда

ЭлементСпискаЗначений = Строка.Значение[0];

лПользователь = ПользователиИнформационнойБазы.НайтиПоИмени(СокрЛП(ЭлементСпискаЗначений.Значение));

ТестовыеДанные.Вставить(ЭлементСпискаЗначений.Представление, лПользователь);

Иначе

ТестовыеДанные.Вставить(Строка.Ключ, Строка.Значение[0].Значение);

КонецЕсли;

КонецЦикла;

ГенераторТестовыхДанных.УдалитьСозданныеДанные(ТестовыеДанные);

ТестовыеДанныеУФ.Очистить();

КонецПроцедуры

&НаСервере

Функция ГенераторТестовыхДанных()

Если ВстроенаВКонфигурацию Тогда

Возврат Обработки[ИспользуемыйПрефиксПодсистемы+"СериализаторMXL"].Создать();

Иначе

Возврат ВнешниеОбработки.Создать("СериализаторMXL");

КонецЕсли;

КонецФункции

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования