MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Получить соединение с базой
06.09.2016
16:41
Автор: pola
Текстовые метки: 1c.integration.templates
Раздел: Программирование - 1с - Интеграция - com - Готовые решения

Функция ПолучитьСоединениеБазы() Экспорт

Перем Соединение;

НачалоСообщения = НСтр("ru = ""Ошибка соединения с внешней информационной базой журнала изменений: """);

РасположениеНаСервере = Истина;

Если РасположениеНаСервере Тогда

СтрокаСоединения = "Srvr=""" + КластерСерверов + """; Ref=""" + ИнформационнаяБаза + """; Usr=""" + Пользователь + """; Pwd=""" + Пароль + """";

Иначе

СтрокаСоединения = "File=""" + ИнформационнаяБаза + """; Usr=""" + Пользователь + """; Pwd=""" + Пароль + """";

КонецЕсли;

Попытка

// Создание COM-соединителя.

Коннектор = Новый COMОбъект("V83.COMConnector");

Для Сч = 1 По 3 Цикл

Попытка

Соединение = Коннектор.Connect(СтрокаСоединения);

Исключение

Соединение = Неопределено;

ТекстОшибки = ОписаниеОшибки();

КонецПопытки;

Если Соединение <> Неопределено Тогда

Прервать;

КонецЕсли;

КонецЦикла;

Если Соединение = Неопределено Тогда

Сообщить(

НачалоСообщения + НСтр("ru = ""ошибка метода Connect: """) + ТекстОшибки);

КонецЕсли;

Исключение

bpСтандартныеПодсистемыПереопределяемый._Сообщить(

НачалоСообщения + НСтр("ru = ""ошибка создания COM-объекта: """) + ОписаниеОшибки());

КонецПопытки;

Возврат Соединение;

КонецФункции // ПолучитьСоединениеВыделеннойБазы()

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования