MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Шаблон script-test.os
06.09.2016
13:57
Автор: pola
Текстовые метки: 1c.oscript.templates
Раздел: Программирование - 1с - oscript - libraries - Готовые решения

#Использовать asserts

#Использовать cmdline

#Использовать tempfiles

Функция ПолучитьСписокТестов(МенеджерТестирования) Экспорт

МассивТестов = Новый Массив;

МассивТестов.Добавить("РежимАвтоВыбираетCFUЕслиОнЕсть");

Возврат МассивТестов;

КонецФункции

Процедура ПослеЗапускаТеста() Экспорт

ВременныеФайлы.Удалить();

КонецПроцедуры

Процедура РежимАвтоВыбираетCFUЕслиОнЕсть() Экспорт

Логирование.ПолучитьЛог("vanessa.app.deployka").УстановитьУровень(УровниЛога.Отладка);

Конфигуратор = СоздатьЗаглушкуКонфигуратора();

РабочийКаталог = ПодготовитьРабочийКаталог();

Команда = Новый КомандаЗагрузитьКонфигурацию();

Режимы = Команда.СоздатьПеречислениеРежимыОбновления();

ВозмРезультат = Команда.СоздатьПеречислениеВозможныйРезультат();

Результат = Команда.ОбновитьВВыбранномРежиме(Режимы.Авто, Конфигуратор, РабочийКаталог);

Ожидаем.Что(Результат).Равно(ВозмРезультат.Успех);

Ожидаем.Что(Конфигуратор.ПараметрыКоманды).Содержит("/UpdateCfg");

Путь = ОбъединитьПути(РабочийКаталог, "1Cv8.cfu");

Нашли = Ложь;

Для Каждого ПутьВПараметрах Из Конфигуратор.ПараметрыКоманды Цикл

Если Найти(ПутьВПараметрах, Путь) > 0 Тогда

Нашли = Истина;

КонецЕсли;

КонецЦикла;

Ожидаем.Что(Нашли).ЕстьИстина();

КонецПроцедуры

← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования