MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Код модуля обычной формы тестовой обработки для отладки
06.09.2016
13:51
Автор: pola
Текстовые метки: 1c.testing.xunit
Раздел: Программирование - 1с - Тестирование - Функциональное - xUnit

Процедура КнопкаВыполнитьНажатие(Кнопка)

НачатьТранзакцию();

xUnit = ВнешниеОбработки.Создать("C:\Projects\xUnitFor1C\xddTestRunner.epf");

ЗагрузитьПлагины(xUnit);

Инициализация(xUnit);

//выполнение тестовых методов

ТестДолжен_ПроверитьРавенствоТаблиц();

Если ТранзакцияАктивна() Тогда

ОтменитьТранзакцию();

КонецЕсли;

КонецПроцедуры

Функция xUnit()

xUnit = ВнешниеОбработки.Создать("C:\Projects\xUnitFor1C\xddTestRunner.epf");

ЗагрузитьПлагины(xUnit)

КонецФункции

Процедура ЗагрузитьПлагины(xUnit)

xUnit.Плагины = Новый Структура;

КаталогПлагинов = "C:\Projects\xUnitFor1C\Plugins\";

НайденныеФайлы = НайтиФайлы(КаталогПлагинов, "*.epf", Ложь);

Для каждого ФайлОбработки Из НайденныеФайлы Цикл

Обработка = ВнешниеОбработки.Создать(ФайлОбработки.ПолноеИмя, Ложь);

Попытка

ОписаниеПлагина = Обработка.ОписаниеПлагина(xUnit.ТипыПлагинов);

Обработка.Инициализация(xUnit);

xUnit.Плагины.Вставить(ОписаниеПлагина.Идентификатор, Обработка);

Исключение

Ошибка = "Возникла ошибка при загрузке плагина: "+ФайлОбработки.Имя + Символы.ПС + ПодробноеПредставлениеОшибки(ИнформацияОбОшибке());

Сообщить(Ошибка);

Продолжить;

КонецПопытки;

КонецЦикла;

КонецПроцедуры

Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования