MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Завершить все сеансы работы с тестовыми приложениями
30.08.2016
16:16
Автор: artbear
Текстовые метки: testing
Раздел: Программирование - 1с - Тестирование - Интеграционное

&НаКлиенте

Процедура ЗавершитьВсеСеансыРаботыСТестовымиПриложениями()

Если массивТестовыхПриложений.Количество() <> 0 Тогда

Для Каждого Подопытный Из массивТестовыхПриложений Цикл

Подопытный.РазорватьСоединение();

КонецЦикла;

ЗавершитьВсеТестовыеПриложенияПринудительно();

КонецЕсли;

КонецПроцедуры

&НаКлиенте

Процедура ЗавершитьВсеТестовыеПриложенияПринудительно()

Утверждения.ПроверитьЗаполненность(массивТестовыхПриложений.Количество(), "массивТестовыхПриложений.Количество()");

Scr = Новый COMОбъект("MSScriptControl.ScriptControl");

Scr.Language = "vbscript";

Scr.AddCode("

|Option Explicit

|

|Dim objWMIService, objProcess, colProcess

|

|Set objWMIService = GetObject(""winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2"")

|

|Set colProcess = objWMIService.ExecQuery(""Select * from Win32_Process Where (CommandLine Like '%/TESTCLIENT%' And ExecutablePath Like '%1cv8c%')"")

|

|For Each objProcess in colProcess

| objProcess.Terminate()

|Next

|");

КонецПроцедуры

← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования