MyTetra Share
Делитесь знаниями!
О, смотри-ка какое хорошее место. Дайте два!
Возникла проблема после обновления X
02.12.2012
17:21
Раздел: linux - gentoo

-Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы)

Добавил(а) Азиз Исаков 3 дня назад

После обновления у меня перестала загружаться компьютер, то есть черный экран при любых старых или новых ядрах. Скачал образ(с KDE) установил с нуля (при установке выбрал модуль Nvidia для видиокарты), обновил систему, перезагрузился... все хорошо. После перезагрузки сделал следующие "module-rebuild -X rebuild" перезагрузился то же черный экран. Попробовал убрать следующую строку в Grub при загрузки "calculate=video:nvidia", загружается только без "X" и почему то вставляет модуль ядра "nouveau". Сделал следующие действия в системе:
1.emerge -1 x11-drivers/nvidia-drivers (откатывался и на более старый модуль ... не помогло)
2.cl-setup-video --video nvidia.
Эти манипуляции не помогли!

Система:
Linux base 3.6.7-calculate
x11-drivers/nvidia-drivers-310.19 (GF 9600)
x11-base/xorg-server-1.13.0-r1

Помогите разобраться!

Ответы (12)

 RE: Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Сергей Стремидло 2 дня назад

присоединяюсь к недоумевающему пользователю, наши ряды растут

лично я сделал
cp /etc/config-archive/etc/modprobe.d/blacklist.conf /etc/modprobe.d/blacklist.conf

какойто сюрприз подкинули разработчики

а еще gcc обновился и скайп не находит libstdc++.so.6

так что ждем пояснений...

 RE: Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Азиз Исаков 2 дня назад

а еще gcc обновился и скайп не находит libstdc++.so.6

это я вылечил вот так

ln -s /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/32/libgcc_s.so.1 /lib32/libgcc_s.so.1

Сделайте по этому примеру.

А что эта манипуляция дает?
cp /etc/config-archive/etc/modprobe.d/blacklist.conf /etc/modprobe.d/blacklist.conf

у меня нет по этому пути каталогов

/etc/config-archive....а дальше пусто??..../etc/modprobe.d/blacklist.conf

 RE: Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Сергей Стремидло 2 дня назад

это при обновлениях нужно использовать dispatch-conf чтобы бекапились изменяемые конфиги, раз нету - вам не повезло, приложу свой конфиг. не менял его вроде. мог только заблеклистить pcspkr - т.е. пищалку. остальное как шло по дистрибутиву.
Обратил внимание в процессе обновления что этот файл чистится, удивился и записал на бумажку. после восстановления его прежнего вида система заработала.

blacklist.conf (1,42 КБ)

 RE: Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Азиз Исаков 2 дня назад

Спасибо 
Буду дома проверю как работает.
Хотя я буду сильно удивлен если так, разработчики должны были предупредить об этом!
Я использую etc-update по привычки.... Но буду иметь веду что так может быть

 RE: Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Сергей Стремидло 2 дня назад

видимо промухали, потому что это както радикально все начало чиститься. косяк видимо в калькулейт утилитах.

обязательно смотрите чего изменяется в конфигах, такие сюрпризы возможны всегда. я обычно ленюсь записывать что вызывает сомнения, но тут как ж чувствовал что не может быть так все радикально.

 RE: SOLVED[РЕШЕНО]-Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Азиз Исаков 2 дня назад

Спасибо!!!
Проблема была именно там, где вы сказали "blacklist.conf" он почему то был у меня пустой! Но так кинуть!!! Разработчики пишите предупреждения! Ведь вы собираете и проводите тест, можно и уведомить! Ощущение что я опять "unstable gentoo". Я ведь и ушел из gentoo на calculate-linux из за стабильности.

Как в старом анекдоте:
«Рабинович, вы у нас вчера были в гостях?» — «Был!» — «Так вот после вашего ухода пропали серебряные ложки!» — «Но я их не брал, я порядочный человек!» — «Но ложки все-таки пропали! Так что больше не приходите к нам в гости!.. Рабинович, ложки нашлись !» — «Так что, можно приходить в гости?» — «Э нет, ложечки-то нашлись , но осадок остался !»

 RE: SOLVED[РЕШЕНО]-Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Сергей Стремидло 2 дня назад

я бы не сказал что это SOLVED, тут нужен офф. ответ, что да, следущим апдейтом устраним или нет, сами вы ...

я тоже перешел с генты, но потому что устал возиться с флагами и сборками ядра. убил ей ssd-винт, отслужил ровно год и одну неделю, т.е. ровно по гарантии. т.е. эксперимент прошел удачно :)

а кальк так быстро ставится и обновляется что просто чудо, но вот нюх оказывается и тут терять нельзя.

я тоже удивлен до глубины души, это ладно на домашних тачках такое, а если обновлять корпоративную сеть и полягут все машины? это на сколько кусков порвут админа который подсадил всех на чудо-дистрибутив? или может мы не так обновляем как предусмотрено? все некогда доку читать

 RE: SOLVED[РЕШЕНО]-Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Alexander Tratsevskiy 2 дня назад

Проблема была именно там, где вы сказали "blacklist.conf" он почему то был у меня пустой! Но так кинуть!!! Разработчики пишите предупреждения! Ведь вы собираете и проводите тест, можно и уведомить! Ощущение что я опять "unstable gentoo". Я ведь и ушел из gentoo на calculate-linux из за стабильности. 

Проблема была в том, что шаблоны настройки пакетов работают с короткими именами. На днях появился новый пакет virtual/udev, шаблон пытался пропатчить blacklist.conf, которого в пакете не было. В итоге шаблон создал пустой конфиг. Исправить можно переустановив sys-fs/udev, либо выполнив обновление всех настроек утилитой 'cl-setup-system'. Чтобы исключить эту и другие подобные проблемы в будущем, в 3.1 beta 2 будут использоваться полные имена пакетов.

 RE: SOLVED[РЕШЕНО]-Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Павел К 1 день назад

Так и не понял как поправить дело. Калька не грузится ни с 3.6.6 ни с других предыдущих версий ядра. У меня KDE x86_64 GF450GTS блоб. На инициализации ядра чёрный экран с помехой в левом краю экрана. dispatch-conf делал и применял изменения...Что можно сделать?

И ещё: второй компьютер с GF9600 обновлять, естественно, не стал, как его обновить, чтобы избежать повтора проблемы?

Исправить можно переустановив sys-fs/udev, либо выполнив обновление всех настроек утилитой 'cl-setup-system'. 

Как это выполнить в моём случае.

 RE: SOLVED[РЕШЕНО]-Возникла проблема после обновления X (x11-base/xorg-server-1.13.0-r1) черный экран (нет загрузки системы) - Добавил(а) Азиз Исаков 1 день назад

Делай так

Запустил ПК - Grub+e - убираешь следующую строку в Grub при загрузки "calculate=video:nvidia", загружается только без "X" - F10- Загрузка - alt+ctrl+F1- root+пароль-монтируешь флешку и копируешь вот это- blacklist.conf - вот сюда- /etc/modprobe.d/blacklist.conf

Это способ верняк, если надо могу сделать в картинках (то есть фото)
где взять
http://www.calculate-linux.ru/attachments/2733/blacklist.conf

или так
http://www.calculate-linux.ru/blogs/show/270

Есть три пути:

  1. Перезагрузить систему, добавив в строке запуска в Grub "nox". В этом случае система загрузится без графического режима.
  2. Во время загрузки нажать "i" и выбирать запускаемые службы, исключив xorg. После загрузки вы попадете в консоль.
  3. Не перегружая систему, нажать волшебную комбинацию клавиш Alt+SySRQ+R. После этого можно перейти в консоль, нажав Ctrl+Alt+F1.

А эти не пробовал

Есть 4 способ.... но он для старых гентушников -сделать chroot+livecd

http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?style=printable&full=1#book_part1_chap5


emerge -1v udev

dispatch-conf


Так же в этом разделе:
← Содержание ...
 
MyTetra Share v.0.35
Яндекс индекс цитирования